Thursday, January 2, 2014

PE11 & 12: Setting Default Video Transition Glitch


tomasz at the Adobe Forums posted "Can't change default transition" in Premiere Elements 12 Windows 7 64 bit Expert workspace, but could in the Quick workspace. The answer seems to come from tomas' own observations and conclusions, and we have confirmed those observations and expanded on them. And, we have found that this "glitch" is present in Premiere Elements 11 as well as 12. Yet we have not found any other mention of it in Adobe documents or in user forums. And, circumstances have been such that we have not run into this situation in our everyday personal Premiere Elements 11 and 12 Windows workflows. The issue was found to be present whether Premiere Elements 11 and 12 were on Windows 7, 8, or 8.1 64 bit.


The Adobe directive is to right click the thumbnail of the transition wanted as default, click on the pop up which specifically says "Set Selected As Default Transition". This set Default Transition thereafter will have a brown frame around it.

What is this "glitch" that prevented tomasz from changing the default transition in Premiere Elements 12 Windows Expert workspace? The answer was that tomasz was in the Expert workspace Transitions using one of the thumbnails under the header of Show All instead of under one of the headers for the thumbnails in an individual category.

Figure 1. Preferences/General Pop Up After Right Clicking A Show All Transition Thumbnail In Premiere Elements 11 or 12 Windows.
The result of tomasz' action in Show All was the pop up of the Preferences/General dialog and not the setting of any default transition. Why?

You do not see this matter in the Quick workspace of either versions 11 and 12 because the Quick Transitions do not have Show All or individual categories of transitions. The Quick Transitions are fewer in number than those found in Expert and exist as a small bunch of video transitions, no individual categories, no Show All.


In Expert workspace, "Set Selected As Default Transition" only exists when working with thumbnail for transition under one of the individual transition categories. That is what the pop up says after you right click the thumbnail there.

However what was overlooked was that, when Show All is the header, the right click results in a pop up that says "Default Transition Duration", NOT "Set Selected As Default Transition". So, in that instance, the program opens to the Preferences/General where default transition duration can be set.

In Expert workspace, the solution is then to use thumbnail for transition under one of the individual transition categories when establishing a new default transition. There is no solution for Quick workspace since issue does not apply there.


The matter presented for question does not appear to be a bug or glitch under the circumstances, but rather a consequence of absence of full documentation for the feature's Show All versus individual transition categories.